Haven't found you're looking for? Visit goodstore howto web

Not compatible with PHP 7?

  • I would like to upgrade my server to use PHP 7.0 (or 7.1).  When I did, the WordPress Admin CP would not load and gave errors.  

    So I used a PHP compatibility checker to make sure all plugins and the theme GoodStore was compatible. All plugins passed the test. However, the theme GoodsStore did not.

    I received the following warning/error message:



    FILE: /home/xxxxx/public_html/wp-content/themes/goodstore/templates/widgets/default_widget_SAMPLE.php
    --------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    --------------------------------------------------------------------------------------------------------
     21 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    --------------------------------------------------------------------------------------------------------


    FILE: /home/xxxxx/public_html/wp-content/themes/goodstore/framework/lib/class_facebook.php
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    FOUND 1 ERROR AFFECTING 1 LINE
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------
     113 | ERROR | Indirect access to variables, properties and methods will be evaluated strictly in left-to-right order since PHP 7.0. Use curly braces to remove ambiguity.
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------


    FILE: /home/xxxxx/public_html/wp-content/themes/goodstore/framework/lib/class_demoimport.php
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    FOUND 1 ERROR AFFECTING 1 LINE
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------
     917 | ERROR | Indirect access to variables, properties and methods will be evaluated strictly in left-to-right order since PHP 7.0. Use curly braces to remove ambiguity.
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------


    In addition, while it resulted in no errors, there were several warnings (16) with the JAW Widgets plugin.  They referred to several lines, and all were the same warning:

     117 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.


    As I understand it, PHP 7 can significantly improve WordPress site performance. I would really like to use PHP 7 here but there seems to be some issues. Can you help?
  • All following comments are shown for registered users only!

    (2 more comments)